[PSO2 NGS] Crashing when entering NGS

I had to edit this post for the third time because different things just kept happening LMAO. But basically after I tried to enter the cocoon on Mt. Piccolt my game crashed, and I can't re-enter NGS without going through PSO2 block transfer first. Now, whenever I want to load into NGS directly I'll crash, and teleporting anywhere does the same thing, too.

@nikkou Finally, I thought I'm the only one who had the same problem. Yes, it started from trying to enter coccon, which in my case my very first cocoon, then as you said the game crashed and I can't re-enter NGS without going through old PSO2.

I can't get out of central town, go to salon, or anything without the sudden crash. No error code or any notification either. The funny thing was everything was fine (I can access everything) BEFORE entering the cocoon.

There's zero solution on the internet either. I've tried:

  1. changing the graphic settings all to low
  2. window mode
  3. restarting my laptop
  4. exclude from antivirus/firewall
  5. re-download the game

And still the problem persist.

if it helps, this is my laptop specs: Ryzen 7, rtx 2060, 16 gb RAM.

I am having this issue all of a sudden too.

@nikkou have you find the solution yet? Another user found that you need to delete SEGA folder on your My documents. It will treat you as a new user if you logged in, but you will still find your character/account bound and the crashing will gone. Do back up your folder first before deleting it.

It solved the crashing for me and other users so it should give you the same results.

@Salanates Thank you! I had a similar problem and deleting the PHANTASYSTARONLINE2_NA_STEAM folder in My Documents solved it for me.