Textures not loading or staying at a very low resolution indefinitely even at high settings

Many textures always look like they're not fully loaded or are stuck in ultra low resolution -- as if they're not being streamed in properly. Relogging does nothing. Restarting the game does nothing. This was not a problem for me on PSO2 classic.

The only way I've found to fix it is to switch to a PSO2 block, and then switch back to an NG block. Nothing else seems to work.

EDIT: Fixed it by setting "SIMPLE GRAPHICS" to Ultra, restarting and then changing settings as normal. The Simple Graphics option seems to actually limit the other ones no matter what you change, despite what the description says.

If I log out and log back in, then I have to repeat this process again, or the textures go back to being low-res.

Example of the problem (ultra low res textures regardless of settings):


Proper high-res textures after fixing it with the method above:


This also affects enemies. They look like blobs of mud.

I just login to old PSO2 and then switch to NGS. It's a lot easier than changing a bunch of settings every time you play the game.

@NuchiMyu I fixed it by setting Simple Graphics to Ultra.
Someoen else suggested it.