Playing with friends?

Hey, i started the game with some friends and we couldnt invite each other. Is it only possible later on in the game? and can we play on the same server? because there is only place for 32 people

Up until after the "Rest" cut-scene once you meet crawford, you can't party with anyone, it's one big solo instance.

It's also worth noting, because this bit me in the arse during CBT: Your Xbox account privacy settings effect in game party rules, and it does NOT tell you this, unless they changed it since beta. I went 2 days of beta w/o getting to party with my alliance, because one of the Xbox privacy settings was set to Friends for parties instead of Everyone. I did want that for Xbox Parties, not in game parties, ffs.

This should only matter if you're logged into an MS version though probably. But in our case, if anyone tried to invite me or vice versa, there was no error, it just didn't arrive on the other side, then in a minute or so the chat log would mention the group invite timed out from not being accepted.

@Drex Yeah, had this probably with roommates. we muted eachother because of our mics and didnt know why we couldnt be in a party together for awhile.

Yeah it was a weird one for me too because I never had this problem on the old game. I don't know if it didn't fully support that particular setting before, or maybe it wasn't applying because I was playing from Steam and the beta was required to be on MS. I was here at the last game's launch, but the MS PC version was REALLY bad and would botch it's installation every few weeks, so once the Steam one became available (and I didn't have a solid alliance I was grouping much for yet back then) I jumped ship real fast.

Until you get on the main city (and unlock the communication) you can't party with anyone. I was with a friend in Discord trying to play together but we couldn't invite each-other till then (and we were on different rooms from the start as well and you can't change that at the start). After that we partied and all was well.

@Drex I've started PSO2 on Steam ...but it was pretty bad ..story progression and other buggy functions made me switch (start from scratch) to M$. It's true that it borked the start ( not the installation per se...at least for me) deleting the game linkage (not the game itself) and that's how PSO2Tweaker was birth. And it actually made possible to adjust some settings the original launcher didn't show (not not permitted...just hidden) and the Res change actually worked unlike the MS original launcher. Since then I never had any troubles, and afaik it was always steam that borked the upgrades (even in the Release it was Steam that had troubles with the Login/download for NGS).

Well, I can't say from my perspective that's even remotely true. With MS they launched with an exclusivity period. I would have preferred Steam to begin with, but it wasn't an option till august. I was actually about to quit because MS was so bad it was botching it's installs at random every 2-3 weeks requiring a full uninstall and reinstall (and it's actually, a lot more complicated than that, because it left 70gb of trash files behind in an admin protected area you can't touch normally without fiddling with permissions, each time it did it. Also since Sega doesn't use large archive files, and instead has over 100k regular files the PC file system has to track, it takes an absurd amount of time to move or delete these) To make matters worse, this problem was not something people would avoid entirely. Every single player would eventually have this happen at some point. Honestly I think this cost Sega a lot of players (at the very least, until the exclusivity ran out) Especially from the less technical players, because reclaiming the 'missing' space locked up in that bizarro windows store cache was not something the casual user knew how to do.

Steam on the other hand has never had that issue because it doesn't do weird fiddly crap hiding itself in protected areas. Personally I've only had 2 updates ever fail with Steam. Both of these actually failed because Tweaker was installed, without it, it never happened. It's actually the reason I stopped using Tweaker too, I only ever really had it setup to swap logins to MS for an MS promo w/o having to install another copy of the game. Ever since Tweaker messed that all up I've been more choosy on if I'll want to mess with an MS only incentive in the future, which is depressing.