An update for the game file has been detected. Restarting application. Please do no cancel when checking the consistency.

When opening application through Steam I get this error:

An update for the game file has been detected. Restarting application. Please do no cancel when checking the consistency.

Please do not cancel when checking consistency.jpg

I downloaded the game twice, had the files checked through Steam and I restarted my computer.

I'll point out they tweeted about this error happening in pso2 before a few months ago and their response was basically to "update" If we think this to be a similar case hopefully by release an update will be there.

If you verify the game files it will redownload the whole game by the way so don't do that if you don't want to try that possible solution.

alt text

Same issue for both me and my gf on different networks and different computers. I have redownloaded the game twice, we're both on Steam.

The entire steam discussions is about this problem as well, it appears to be exceptionally widespread. Might wanna acknowledge the issue and post something official on Steam before the community gives up and it goes DoA on Steam.

Ive got multiple friends with the same issue, trying to diagnose it now with them. 2 out of 5 of us are having the issue. This will ruin our start together if this isn't fixed in time for launch or if we spend to much time figuring it out on our own. While one of us COULD run a USB drive with a copy of it to them etc, we can't do that for the other as they are out of country.

@Letozeth Yeah, I'm not a current player of PSO2 at all. My friend and I both thought we'd try it. But we both got this error. After reinstalling it and not having any luck or seeing any official post on it I'm just going back to playing WoW Classic TBC... Ahh well, maybe I'll look into this in a few months after they've fixed things up.

the solution is to use arklayers , because ive been having the same issue with steam, so after downloading it twice and failing to get to the launcher I finally tried arkslayer link it with my steam files and it worked

Tweaker has many problems too with pso2bridge dll, and other things. I would say to wait till launch

Question, are the people having this problem new installs of pso2/first time players, my brother is having the same problem and he didn't install till the game updated to "NGS" as where i have been playing base pso2 for a long time and I was able to get right to the launcher without issues to far.

That seems to be the case for 2 of my buddies. Out of the 5 of us 2 are having issues that are fresh installs vs updates. One hasnt reported any issues because they havent been on tho so it might be 3 out of 5. oh boy. Just waiting to hear of good fixes till we try lots of things.

Thanks for all the comments! This was a fresh install. no prior PS02 was on the system.

Fresh Steam install, not a current/ returning player, and I experienced the exact same issue. I verified file integrity and oh boy was that ever a mistake. Steam opted to download the entire 90GB game all over again; same issue on re-try/ post second download. I'm just going to wait until official launch to try again (but not getting my hopes up), sketchy game releases have been a dime a dozen over the past decade.

Thanks for all the responds guys, from what I've been able to gather this is an issue that's happening to people with fresh installs that didn't update a currently installed version of pso2. I have a theory that it has something to do with fresh downloads not containing the proper files for the launcher or some conflicting files, where as people who updated already had the files for the launcher so it was just an upgrade process but like I said that's just all theory and I have no solid evidence just a conclusion I've come too after reading around and stuff haha.

Working solution:

  1. Press Win+R to open the Run dialog
  2. Run %LocalAppData%
  3. Create a directory SEGA if it doesn't exist yet. Open it.
  4. Create a directory PHANTASYSTARONLINE2_NA_STEAM if it doesn't exist yet. Open it.
  5. Create a file name steamupdate.txt by right clicking > New > Text Document (IF FILE EXTENSIONS ARE HIDDEN IN YOUR EXPLORER, JUST NAME IT steamupdate)
  6. Open it in Notepad
  7. Put the text v70000_rc_135

Voila. Your launcher will work again. Repeat these steps if it breaks.