NG Benchmark Application giving blank error and not opening from launcher

Me: downloads and run NG benchmark ApplicationNGBM: give blank error and will not open even after changing setting and trying to run in windowed or full screenAlso Me: bruh

For real some please give me a fix for this I do have the specs to run this so I will list my specs and please for my sanity DO NOT GIVE ME REPLIES SAYING "YOUR SPECS CAN'T RUN IT" please I am just looking for a fix to this a few friends were able to run it no problem and one of them is from a country using fake PC parts because Brazil. So please I need a fix here are my basic specs

PC SpecsGPU: Nivida GTG 1050CPU: AMD Phenom(TM) II( means 2) X4 925(yes I am aware that it's old but runs just fine with any newer game on max settings no problem)RAM: 24GB1167affb58d89f9843ba7088e0c01a09.png

The CPU must support AVX and yours does not, so you unfortunately won't be able to play NGS or even PSO2 when it gets the graphics update

@Ragnawind So let me get this straight? After the update I might not be able to play it anymore after putting in hours of hard work and some of my spare funds I had spent on this and all the work I put into this game I won't be able play this or NG anymore and it's basically PSO2 staff telling me to "Fuck off"?

If so I would like my money back that I spent playing because I enjoyed this game I really did and now I am pissed that one update is gonna permanently prevent me from playing.

The reason I feel like this is I am not like everyone else I can't simply go out and buy a new CPU and then have to guess if it will run on my system I am not gonna spend like $100+ on a part I feel is gonna fuck me over sideways in the end.

I am sorry but this upsets me and that I will soon be unable to play this game anymore something I actually enjoyed after that update comes out I am uninstalling this piece of crap game because it's bad enough with all the requirements and errors I get through each update that involve me having to verify the game files and everything and wait like 6 hours for it to reinstall despite having good internet and being hardwired into my modem.

Sorry but I think I am done with this game thanks for giving the bad news. not your fault but I feel like shit now.

There are cpus $50 and below that can run avx instructions. Its really that old. Might be worth checking your motherboard compatibility

@Zengo said in NG Benchmark Application giving blank error and not opening from launcher:

Me: downloads and run NG benchmark ApplicationNGBM: give blank error and will not open even after changing setting and trying to run in windowed or full screenAlso Me: bruh

For real some please give me a fix for this I do have the specs to run this so I will list my specs and please for my sanity DO NOT GIVE ME REPLIES SAYING "YOUR SPECS CAN'T RUN IT" please I am just looking for a fix to this a few friends were able to run it no problem and one of them is from a country using fake PC parts because Brazil. So please I need a fix here are my basic specs

PC SpecsGPU: Nivida GTG 1050CPU: AMD Phenom(TM) II( means 2) X4 925(yes I am aware that it's old but runs just fine with any newer game on max settings no problem)RAM: 24GB1167affb58d89f9843ba7088e0c01a09.png

Meant GTX not GTG.

@Pok Yeah if you want fake or live in Brazil where those prices are the only option please don't give me any false advice or prices okay? thank you. If I seem rude I assure you I am not.

@Ragnawind yo, sorry that happened, I and a friend talked with Zengo via Discord about this issue, and he refused to reason in any way. I still decided to apologize on my friend's stead.

@Zengo It's unfortunate, but, old hardware is not going to be supported forever, sometimes there is no choice but to quit or upgrade hardware. It's the same thing that happened to PS Vita players in the JP version, support for the PS Vita version has also ended, Vita players have no choice but to quit or change to another platform.

On another note, Phenom II is older than it looks like, it released in 2009, that means that nowadays Phenom II is as old as Pentium 3 was back in 2009...

@Ragnawind said in NG Benchmark Application giving blank error and not opening from launcher:

The CPU must support AVX and yours does not, so you unfortunately won't be able to play NGS or even PSO2 when it gets the graphics update

While I am not denying this could be a possibility (the base PSO2 not working), it hasn't been confirmed. NGS requiring AVX is right though.

@Zengo You seem to be spouting a lot of nonsense for something that is speculation for now.

@FANtasyStarOnline said in NG Benchmark Application giving blank error and not opening from launcher:

@Ragnawind said in NG Benchmark Application giving blank error and not opening from launcher:

The CPU must support AVX and yours does not, so you unfortunately won't be able to play NGS or even PSO2 when it gets the graphics update

While I am not denying this could be a possibility (the base PSO2 not working), it hasn't been confirmed. NGS requiring AVX is right though.

@Zengo You seem to be spouting a lot of nonsense for something that is speculation for now.

If someone plays JP right now and doesn't have an AVX CPU, that would be proof of that. If they can't right now, that would mean it is impossible to play without AVX on even the base game. I just don't have a PC anymore that doesn't have AVX to check.

@FANtasyStarOnline @Ragnawind There's an user in the PSO-World forums that used to play in the JP version, that user has a CPU that doesn't support AVX (AMD Phenom 9150e) and hasn't been able to play since the graphics update:

https://www.pso-world.com/forums/showthread.php?213385-Quick-Questions-Come-here-for-quick-answers!/page4676&p=3479798#post3479798

Looks like it's time for a CPU upgrade, even if it's every 8-10 years, you might not be able to play PSO2 after the graphics update either, sorry to say.

@Ragnawind

@Ezodagrom said in NG Benchmark Application giving blank error and not opening from launcher:

@FANtasyStarOnline @Ragnawind There's an user in the PSO-World forums that used to play in the JP version, that user has a CPU that doesn't support AVX (AMD Phenom 9150e) and hasn't been able to play since the graphics update:

https://www.pso-world.com/forums/showthread.php?213385-Quick-Questions-Come-here-for-quick-answers!/page4676&p=3479798#post3479798

That feels like some pretty solid evidence to me! That's unfortunate for some, hopefully not too many, players.

@FANtasyStarOnline said in NG Benchmark Application giving blank error and not opening from launcher:

@Ragnawind

@Ezodagrom said in NG Benchmark Application giving blank error and not opening from launcher:

@FANtasyStarOnline @Ragnawind There's an user in the PSO-World forums that used to play in the JP version, that user has a CPU that doesn't support AVX (AMD Phenom 9150e) and hasn't been able to play since the graphics update:

https://www.pso-world.com/forums/showthread.php?213385-Quick-Questions-Come-here-for-quick-answers!/page4676&p=3479798#post3479798

That feels like some pretty solid evidence to me! That's unfortunate for some, hopefully not too many, players.

It isn't that many players. A lot of them even have upgrade options, so long as they are on desktop and their socket type is of a certain type. The majority of PC gamers outside Japan, at least, also have or had a Steam account at some point, and according to their statistics, apparently over 90% have a CPU that supports AVX.

Are AMD processors not supported at all or just the older ones?