Luster Voltage/Gear Bars not showing

This is the first time i'd took notice to this bug. I'm pretty sure it showed up today as of writing this (2/26).

The issue is that the gear bars and the voltage counter are not showing, i tried changing classes, didn't work, and the Luster class had no name for some reason. And when playing with it, it felt like the voltage sometimes didn't count up. I also logged in and out, but sadly, nothing.

Is it only me? Or did anyone else experience this bug?

well voltage won't show or work if you didn't put a skill point in luster voltage skill also voltage won't grow unless it hits a enemy so objects that can attack like the cannons you find in Armada UQ won't increase voltage count or even reset the bar.

now the gear bar not showing is weird, if you are using a gunblade it should always be there while using Luster as main class.

@Jamesmor I've been playing the class for a while, the numbers for voltage sometimes pop in and out of the place they should be at, the counter itself isn't there as well, it's 100% a bug and not intended.

It might be some corrupt files. Have you tried running a file check?

@AndrlCh Did that, and it worked, thank you.