Controller Issue

I have a Logitech controller - most games recognize it as an XBox controller for control sakes. Anyways, it works just fine in every single game I play, online and offline, but not this game for some reason. I went into the game settings and changed it to the controller, seems like it should work, but still only accepts keyboard/mouse. The controller is Logitech Gamepad F310, USB. - Again, no issues in any other games until I just tried this game out. I'm probably missing something very obvious. The other controller topics were flooded with a lot of chatter, didn't see much going on for direct help.

  • Thank you 🙂

a5340cc8-4a78-4c72-bb45-a18e84852609-image.png

I set the Primary Control Device to 'Controller' then apply changes, when I check it again, it still has it highlighted as keyboard & mouse. I can't seem to fix this at all.

SOLVED: You have to have Steam Big Picture open. Didn't even know that was a thing honestly. Never needed it before.

Are you using the Steam version or Microsoft Store version? If you used the MS Store version, even if through the Tweaker, that might be the issue. There is a weird un-fixable issue with controllers on Windows 10. Sometimes, if you unplug a controller or plug it in after the computer is already signed in, the controller is detected as Port 2 or higher. The only fix I have found for that, without using Steam, for the MS Store version through the Tweaker, is to sign out of Windows 10, unplug the controller, plug it back in, and sign back in. This will have the controller in Port 1 and it won't need Steam Big Picture to control the controller.

It would be so much easier if Microsoft added a way within Windows 10 to adjust the Controller's port number. They had this in Windows 7 and before, but not in Windows 10.