Error 630

Gm won't reply in technical forum , let's try here , Error 630 after UQs daily , not my internet soooooo what to do now ?

Only ideas I can think of is if you are on PC try a different install method (ms store/steam/tweaker). If you're on xbox, hope they fix it? Not much you can do. Could try redownloading the client I guess.

@TsundereMuse said in Error 630:

Only ideas I can think of is if you are on PC try a different install method (ms store/steam/tweaker). If you're on xbox, hope they fix it? Not much you can do. Could try redownloading the client I guess.

Im gonna try that but doubt.

On Xbox , tried re installing twice , still getting error 630 after UQs at the loot crystal

Error 630 can happen for many reasons but main ones I have seen is:

  1. Server connection issues (This is on SEGA's side not much you can do here except send in a ticket or try their Twitter)
  2. Your connection to the server is unstable (can be due to number 1 but also can be your internet causing it)
  3. some sort of client corruption (rarely happens and a reinstall would fix it but since you did that it is either 1 or 2 I feel)

Thx for the info , when I get error 630 , it says I've lost connection to pso server but I'm still connected to Xbox live , so if I lost internet connection , wouldn't it kick me off Xbox live and sign my gamertag out , but doesn't do that and I'm still connected to Xbox and my internet is was fine , So it's a problem on there end.

Me and my friends are starting to get them again. Maybe something happened during maintenance? I use the tweaker and I talked to my ISP, saying it's not on their side, which added salt to the wound since they now started to charge you for calling them...

Bump.......

Keep this up top

Please stop bumping this since it is semi against the forum rules as stated here: https://forum.pso2.com/topic/72/phantasy-star-online-2-community-guidelines This comes under rule 2a of those rules since in a way this is pure gibberish (I am not trying to impersonate the PSO2 team or anything but giving a friendly warning)

I'm also on xbox and had the same issue a few nights this past week. It's an issue with xbox live cause it was happening with every game i attempted to play. Even gave up on server based games and thought I'd play some Cyberpunk 2077 and was booted back to the home screen and told i "need to be online" in order to play. Current xbox service is pretty trashy at best. Hope you're able to enjoy your games soon.

Just dc'd perfect connection, mid UQ. Doesnt seem like they plan on fixing this either.

I'm not trying to break any rules posting , but this keeps happening so I want to keep this post alive til we get some kind of answer

You know that GM Sirius responded to one of the many 630 error threads in the Technical section 3 days ago, so what more are you expecting by posting this in General? This problem has existed for a long time and as an Xbox player who has lost loot I share your frustrations. But they're aware of the issue so there's not much more we can do aside from submitting tickets to the dev team and waiting for a permanent fix (which my guess is won't come until the graphical update in a couple months or even NGS).

@Rang-Dipkin Well, I did look at those threads and, yeah I should've sent a ticket, but to me it just seems like it becomes common again after something happens during some maintenances. I'm not sure what it is though, but as I said earlier, it's not my ISP and I really don't want to get charged for asking about the same thing and getting the same answer only for the cycle to continue. Granted I haven't run into any more 630's, but you never know when it'll pop up, right?